Posts by omega1848

    Wie am einfachsten bestehende SBS 2003 Server 1:1 austauschen bzw. Clients übernehmen?


    Zurzeit haben wir eine SBS 2003 Premium Serverlandschaft mit 10 Clients im Einsatz, funktioniert auch soweit eigentlich ganz gut.
    Allerdings muss der Server jetzt wegen diversen Hardwareproblemen komplett ausgetauscht werden.
    D.h. somit würde ich dann auch den SBS 2003 neu aufsetzen (inkl. Exchange und SQL Server).
    Ich würde gerne die bisherige Namensgebung des Active Directory, Exhange, SQL Server etc. beibehalten.
    Inklusive der Usernamen, Gruppen, Printernamen, Berechtigungen, etc. und würde gerne verhindern das ich noch mal jeden Client irgendwie „anfassen“ muss.


    Also im Prinzip folgendes Szenario:
    Alle User arbeiten mit dem alten Server bis Freitagabend, ich komme Samstagmorgen mit dem neuen Server (schon vorab vorbereitet und installiert) vorbei, bau den alten Server ab und stell den neuen Server hin.
    Am Montag schalten die Mitarbeiter ihre Rechner, Laptops, etc. ein und alles funktioniert wie gehabt, also ohne das die noch mal irgendwie sich neu an der Domain joinen müssen oder ähnliches.
    Geht so was überhaupt, oder macht mir da die SID UID (was ist das??) der einzelnen Clients bzw. der Domain einen Strich durch die Rechnung?
    Was ist der einfachste Weg mit möglichst geringem und einfachen (!) Aufwand, da ich das Netzwerk auch nur „übernommen“ habe und auch kein „Berufsadmin“ bin (ist eine kleine Firma mit 10 Clients…).


    Vielen Dank für eure Hilfe vorab!!!


    Grüße

    Nachtrag:
    Ping geht jetzt (Peinlich, mein Fehler, Firewall Settings).


    Habe DHP mal deinstalliert und neu installiert, damit ist dann die o.g. Fehlermeldung verschwunden.
    Im Event Viewer sind keine Fehlermeldungen, aber die Clients bekommen immer noch keine IP Adressen :(


    Was ich aber auch nicht vergesse, warum manuell nix geht, sprich ich habe mal manuell einen Client mit IP Adresse 10.1.1.20, Subnet mask 255.255.255.0, Gateway 10.1.1.1 und DNS 10.1.1.10 eingetragen.
    Ping zum Server geht, aber ping zu bc-srv-1 (Servername) geht nicht, auch Internet Namensauflösung zu ww.ibm.de oder sonstige Internet Seiten geht nicht (auf dem Server geht Internet aber einwandfrei...).
    Es sieht also so aus als ob irgendwo im DNS noch ein Fehler ist, hatte es aber wirklich so wie oben in der Anleitung gemacht, seltsam...

    Hallo,
    ok, also jetzt habe ich es so wie vorgeschlagen gemacht.
    Also DHCP, DNS und Active Directory auf dem Server.
    Dabei bin ich strikt nach den Anleitungen unter http://www.wintotal.de/Artikel/w2003server3/w2003server3.php und http://www.unterwegs-im.net/content/view/8/8/ vorgegangen.


    So, wenn ich dann auf den Server NSLOOKUP mache, kommt auch die richtige Antwort, öffne ich dann z.B. auch mal eine Webseite, funktioniert die Verbindung einwandfrei.
    Setze ich dann ein Ping 10.1.1.1 (der Server hat bei mir 10.1.1.10), Subnet 255.255.255.0 an das Gateway funktioniert das auch einwandfrei.
    Jetzt kommt aber das 1. Problem: Setze ich nun einen zusätzlichen Client ins Netzwerk und stelle dort erstmal die IP Adresse manuell ein mit 10.1.1.20, Subnet Mask 255.255.255.0, Default Gateway 10.1.1.1 und DNS Server mit 10.1.1.10, dann kann ich zwar wunderbar ein Ping an das Gateway machen, NICHT aber an den Server!
    Auch der Server liefert ein erfolgloses Ping an den Client 10.1.1.20 zurück!


    Ok, habe ich mal einen Moment ausser acht gelassen und auch auf dem Server DHCP installiert (gemäss Anleitung siehe oben, bzw. mit den Wizard).
    Dort als Range 10.1.1.50 - 149 eingestellt, Subnet Mask 255.255.255.0 und Default Gateway 10.1.1.1 und DSN 10.1.1.10.
    Das hilft aber auch nichts, die Clients bekommen keine Adressen zugewiesen, ich kann machen was ich will.
    DNS und DHCP Dienste laufen aber lt. MMC (alles grün) und der DHCP wurde auch gemäss Anleitung "authorisiert".


    Seltsamerweise habe ich aber im Event Viewer unter System eine blöde Fehelermeldung "DHCP Server"= The DHCP service has detected that it is running on a DC and hos no credetials configured for use with Dynamic DNS registration innitiated by the DHCP service. This is not a recommended security configuration. Credentials for Dynamic DNS regisrattions may be configured using the command line "netsh dhcp server set dnscredetials" or via the DHCP Administrattive tool", ok und was bedeutet das nun?


    Bin wie immer um jeden Tipp und Hilfe dankbar!


    Bzw. ich verstehe einfach nicht, warum der Server noch nicht mal über ein Ping erreichbar ist, bzw. die anderen Rechner nicht über Ping vom Server...
    Wenn ich z.B. noch einen Rechner reinhänge und den mit 10.1.1.21 (Subent Mask 255.255.255.0, Gateway 10.1.1.1 und DNS 10.1.1.10) eintrage, finden sich die beiden Clients 20 und 21 ohne Probleme via Ping.
    Also scheint das "Problem" ja am Server zu liegen, aber welches?
    Ich verstehe es leider nicht :(


    Grüsse und Danke vorab!!!

    Sorry, ein Punkt hatte ich noch vergessen warum das ganze so "kompliziert" ablaufen soll:
    Es soll gewährleistet sein, dass wenn der Server "down" ist, trotzdem die Mitarbeiter ohne Probleme ins Internet (und somit auch an ihre Mails beim Provider) kommen, daher die Vorgabe das der "Router" die Infrastruktur-Oberhand hat.


    Denn wenn ich es richtig verstehe, wenn der Server DNS und DHCP macht und dann ausfällt, dann geht gar nix im Netzwerk, korrekt?
    (Ausser die User ändern alles handisch per Hand, etc.)


    Danke und Grüsse

    Windows 2003, DHCP und DNS vom Router und trotzdem Active Directory?
    Hallo,
    Ich habe zwar schon mehrmals die Suche bemüht und mich auch durch diverse DNS Artikel gelesen, aber irgendwie fehlt mir das DNS Verständnis. Auch das diverse Konfigurieren und Ausprobieren hat vermutlich jetzt noch zu mehr Problemen und Fehlern geführt, die mir nicht unbedingt beim Verständnis helfen.
    Ich suche daher quasi eine Anleitung für DNS und Active Directory Dummies, aber vielleicht schildere ich erst mal das Szenario bzw. was ich machen möchte:
    Es soll ein kleines Netzwerk installiert werden mit 5 Arbeitsplätzen.
    Der Zugang der Arbeitsplätze zum Internet und das abholen der Emails beim externen POP3 Mailprovider (es ist nicht gewünscht oder notwendig einen eigenen Mailserver im Firmennetzwerk zu betreiben) soll über den DSL-Router erfolgen. D.h. die IP Adressen sollen dynamisch mittels DHCP vom DSL Router an die Arbeitsplätze vergeben werden.
    Somit soll auch die DNS Namensauflösung vom DSL Router ?gesteuert? werden.
    Zusätzlich soll nun noch ein Windows 2003 Server installiert werden, der als File Server fungiert und auf dem das Active Directory installiert sein soll, zwecks Zugriffskontrolle der Dateien, etc.
    Geplant ist dem Windows 2003 Server eine feste IP Adresse zu vergeben.


    Internet --- DSL Router -------------- Win 2003 SRV
    +----------- Notebook 1
    +----------- Notebook 2
    etc.
    Nun stellt sich für mich die grosse Frage, wie ist das AD und DNS einzurichten?
    Ein wichtiges Detail noch dazu: Der verwendeten Arbeitsplätze sind überwiegend Notebooks, die auch oft im Aussendienst eingesetzt werden. D.h. konkret das sämtliche Einstellungen wie IP Adresse, DNS, WINS (was auch immer) bei den Arbeitsplätzen dynamisch und automatisch erfolgen sollen!
    Denn das Problem ist, dass die Mitarbeiter nicht fit genug sind selber IP Adressen einzutragen, diese wieder auf DHCP umzustellen etc., sprich das die Leute auch zu Hause, oder im Internet Cafe sofort ihr Notebook benutzen können.
    Somit stellt sich z.B. für mich auch die Frage welchen DNS Server bekommen die Clients zugewiesen? Den vom Router automatisch? Aber wenn das der Fall ist, dann finden die vermutlich den Server im Active Directory nicht und können nicht der Domain hinzugefügt werden? Etc., etc.
    Gibt es für diese Anforderung vielleicht irgendwo eine detailierte Schritt für Schritt Anleitung? Ich habe irgendwie scheinbar alles vermurkst und denke es macht Sinn nochmal bei 0 anzufangen und zu installieren.
    Vielen Dank für eure Mühe und Hilfe vorab!
    Grüsse
    Oliver

    Hallo,
    ich habe nun einen SBS2003 Premium (also inklusive ISA) aufgesetzt und dabei leider immer wieder das Problem das Emails in der SMTP Warteschlange ?hängen? bleiben und dort nicht gesendet werden.
    Wenn ich in die Warteschlange hereinschaue bekomme ich die Meldung:
    "SMTP konnte zu keinem DNS-Server eine Verbindung herstellen"
    Komischweise passiert dies nicht immer, sondern nur mach mal. D.h. das Problem tritt nicht dauernd (!) auf, nach einem Reboot des Servers ist wieder alles in Ordnung und er verrichtet dann einwandfrei seine Arbeit.
    Woran kann dies liegen?
    Folgende Einstellungen sind gemacht worden bzw. folgendes Setup haben wir


    Wie haben eine feste IP Adresse 217.91.x.x
    Lokaler DSL Route mit fester IP Adresse 217.91.xx fürs Internet und mit der lokalen IP Adresse 10.1.2.1, Subnet Mask 255.255.255.0 zum SBS 2003.


    Dort ist dann der SBS 2003 Server mit 2 Netzwerkkarten ausgestattet:


    WAN Netzwerkkarte IP Adresse: 10.1.2.10 (per Kabel an den Router anschlossen)
    Subnet Mask 255.255.255.0
    DNS: 10.1.1.10 (komischerweise ist dies hier als DNS eingetragen wenn an die Ntzerwekkarten Eigenschaften beim Server für die WAN Karte aufruft, müsste da nicht 10.1.2.1 stehen? Oder wird dies über DNS Weiterleitung aufgelöst? Siehe Erklärung weiter unten..)


    LAN Netzwerkkarte IP Adresse : 10.1.1.10 (von dort per Kabel an den Hub / Switch, und dort dann alle Clients, Drucker, etc.)
    Subnet Mask 10.1.1.10
    DNS: 10.1.1.10


    Auf dem Server läuft der DNS Server unter der Adresse 10.1.1.10 und auf der Registerkarte ?Weiterleitung? ist 10.1.2.1 eingetragen.
    WINS läuft scheinbar auch auf dem SBS.


    ISA 2004 ist auf dem Server auch installiert, zusätzlich ist eine Regel installiert, die es erlaubt SMTP und POP3 Anfragen vom lokalen Netzwerk nach 10.1.1.10 bzw. auch auf Externes Netzwerk durchzulassen.


    POP3 Verbindungen z.B. von Outlook 2003 bei den Clients zu einem externen Mailprovider funktionieren.


    Wenn man nun auf dem Server den Browser aufmacht, funktioniert Internet einwandfrei, ebenso alle angeschlossenen Clients.


    Bei den Exchange Einstellungen ist der Smarthost (Mailserver vom Provider smtp.1und1.de) eingetragen und auch die Authentifizierung mit dem passenden Konto funktioniert.
    Zusätzlich ist noch POPcon installiert (gemäss der Anleitung von POcon) und funktioniert auch einwandfrei.


    Test per Telnet smtp.1und1.de auf dem Server via MS DOS Prompt funktioniert auch, smtp.1und1.de wird aufgelöst.


    Wie gesagt, das Problem tritt nicht immer auf, d.h. irgendwie tue ich mich wahnsinnig schwer nachzuvollziehen an was es liegen könnte.
    Spinnt eventuell der ISA Server rum?
    Oder liegt hier wirklich ein primäres DNS Problem / Konfigurationsfehler vor (siehe WAN Karte oben)?




    Vielen Dank vorab!
    Grüsse

    Hi,
    wir wollen einen SBS 2003 Premium aufsetzen, mit möglichst guter Sicherheit und den folgenden Funktionen bzw. Setup:


    - Feste IP Adresse vom Provider
    - POP3 Mailboxen (leider, Anbieter bietet kein SMTP an)
    - VPN Zugang von draussen aufs Firmennetzwerk
    - Outlook RPC HTTP Sync von extern mit dem Exchange Server
    - Die üblichen Sachen wie Mail (SMTP, POP3), MSN Messenger, Skype (inkl. VOIP) sollen natürlich auch gehen.


    Set up:
    SBS2003 Premium mit 2 Netzwerkkarten.


    Internet-> feste IP Adresse vom Provider -> daran dann den DSL Router mit Range 10.1.1.x -> daran dann über Netzwerkkarte1 der Server -> Netzwerkkarte2 dann an den internen Firmenhub-/switch an dem dann alle Clients hängen mit Range 10.1.2.x oder was auch immer.


    Nun meine Fragen:
    - Bringt das Setup überhaupt irgendeine Sicherheit?
    - Wo sollte dann der DNS und DHCP Server für das Firmennetzwerk "liegen"? Auf dem DSL Router oder auf dem SBS2003? (d.h. entweder muss dann der Router immer durchreichen oder eben der SBS2003)?
    Hintegrund der Frage: Falls mal der Server komplett ausfallen sollte, wäre es gut wenn die Clients im Firmennetzwerk trotzdem schnell wieder ins INternet kommen könnten (Dabei müsset man natürlich dann händisch das Kabelm von der NIC2 direkt an den DSL Router umstecken, da es ja sonst keine direkte Verbindung mehr gibt...)
    - Welche PORTS müssen wie vom DSL Router weitergeleitet werden bzw. eingetragen werden, damit die oben gewünschten Sachen beim SBS funktionieren (VPN, Outlook RPC, Skype, etc.)?


    Vielen lieben Dank für eure Hilfe vorab!
    Grüsse
    Oliver